Getting Started

Using Yasumi in your projects is super easy! Yasumi is available on Packagist and can be installed using Composer.

System Requirements

You need PHP >= 7.2 to use Yasumi, but the latest stable version of PHP is recommended. Yasumi is verified and tested on PHP 7.2, 7.3 and 7.4. Other versions of PHP are no longer supported.

In case you are still using the previous major release of Yasumi (v1.8.0) with PHP 5.x, a bug fix release has been made available for the v1.8 branch. You can read more about it here: Welcome Yasumi version 2!. However, it is strongly recommended upgrading to PHP 7 and Yasumi v2.0.0.


Installation

Install azuyalabs/yasumi using Composer by issuing the following command:

$ composer require azuyalabs/yasumi

Be sure to include the Composer autoload file in your project:

<?php

require 'vendor/autoload.php';

// Use the factory to create a new holiday provider instance
$holidays = Yasumi\Yasumi::create('USA', 2020);

That's all it takes, you're ready to go!

Interested in learning more about Yasumi? Have a look at the Cookbook section; this section includes various recipes, examples and how-to's to get started with Yasumi.


Last updated 06/22/2020